Sets the collection of externally added items which should be shown in the Transfer Project Standards dialog as options.
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017.2
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- externalItems
- Type: System.Collections.GenericIDictionaryGuid, String
The external items which are displayed in the Transfer Project Standards UI. GUIDvalue is used to identify the external item string.
Remarks
The externally added items that the user opted to transfer will be reported in the args to the TransferredProjectStandards event.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |