SharesSettings Property


Identifies whether settings are shared globally.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public bool SharesSettings { get; set; }
Visual Basic
Public Property SharesSettings As Boolean
	Get
	Set
Visual C++
public:
property bool SharesSettings {
	bool get ();
	void set (bool value);
}

Remarks

Identifies whether the per-view SunAndShadowSettings element shares global settings. Global settings are a special case that allows multiple views to be associated together in order that a change in one view affects that same change in other views. There cannot be multiple such groups, and a SunAndShadowSettings element is either a global setting or not.

See Also