ContainsKey Method


Checks whether a pattern key exists in the table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public bool ContainsKey(
	ExportPatternKey exportpatternKey
)
Visual Basic
Public Function ContainsKey ( _
	exportpatternKey As ExportPatternKey _
) As Boolean
Visual C++
public:
bool ContainsKey(
	ExportPatternKey^ exportpatternKey
)

Parameters

exportpatternKey
Type: Autodesk.Revit.DB ExportPatternKey
The export pattern Key.

Return Value

True if the pattern key exists in the table.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also