GetRuleName Method (PerformanceAdviserRuleId)


Retrieves the name of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public string GetRuleName(
	PerformanceAdviserRuleId id
)
Visual Basic
Public Function GetRuleName ( _
	id As PerformanceAdviserRuleId _
) As String
Visual C++
public:
String^ GetRuleName(
	PerformanceAdviserRuleId^ id
)

Parameters

id
Type: Autodesk.Revit.DB PerformanceAdviserRuleId
The rule id to get information for.

Return Value

The name of the rule.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also