LevelOfDetail Property


An number between 0 and 1 (inclusive) specifying the level of detail for the triangulation of a solid or shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public double LevelOfDetail { get; set; }
Visual Basic
Public Property LevelOfDetail As Double
	Get
	Set
Visual C++
public:
property double LevelOfDetail {
	double get ();
	void set (double value);
}

Remarks

Smaller values yield coarser triangulations (fewer triangles), while larger values yield finer triangulations (more triangles).

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: The given value for levelOfDetail must lie between 0 and 1 (inclusive).

See Also