GetPanel Method


Get the specified panel located by the intersection of the grid lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public Panel GetPanel(
	ElementId uGridLineId,
	ElementId vGridLineId
)
Visual Basic
Public Function GetPanel ( _
	uGridLineId As ElementId, _
	vGridLineId As ElementId _
) As Panel
Visual C++
public:
Panel^ GetPanel(
	ElementId^ uGridLineId, 
	ElementId^ vGridLineId
)

Parameters

uGridLineId
Type: Autodesk.Revit.DB ElementId
The id of a grid line in the U-direction used to locate the panel.
vGridLineId
Type: Autodesk.Revit.DB ElementId
The id of a grid line in the V-direction used to locate the panel.

Return Value

The panel, or a null reference ( Nothing in Visual Basic) if the panel cannot be found at this intersection.

See Also