GetExcludedCategoryIds Method


Returns ElementIds for Category elements which are excluded by route calculation.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since: 2020

Syntax

C#
public ICollection<ElementId> GetExcludedCategoryIds()
Visual Basic
Public Function GetExcludedCategoryIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetExcludedCategoryIds()

Return Value

The ids of Categories which are excluded by route calculation.

See Also