CanBeDivisionProfile Method (ElementId)


Checks whether a family defines a profile which can be used by this method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public bool CanBeDivisionProfile(
	ElementId familyId
)
Visual Basic
Public Function CanBeDivisionProfile ( _
	familyId As ElementId _
) As Boolean
Visual C++
public:
bool CanBeDivisionProfile(
	ElementId^ familyId
)

Parameters

familyId
Type: Autodesk.Revit.DB ElementId
Element id of the family.

Return Value

True if the family defines a profile which can be used by a part maker, false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also