GetAllRuleIds Method


Retrieves an enumeration of rule Ids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public IList<PerformanceAdviserRuleId> GetAllRuleIds()
Visual Basic
Public Function GetAllRuleIds As IList(Of PerformanceAdviserRuleId)
Visual C++
public:
IList<PerformanceAdviserRuleId^>^ GetAllRuleIds()

Return Value

A collection of rule Ids

See Also