RuleValue Property


The user-supplied global parameter value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2017

Syntax

C#
public ElementId RuleValue { get; set; }
Visual Basic
Public Property RuleValue As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ RuleValue {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also