CreateHasValueParameterRule Method


Creates a filter rule that determines whether an element's parameter has a value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since: 2020

Syntax

C#
public static FilterRule CreateHasValueParameterRule(
	ElementId parameter
)
Visual Basic
Public Shared Function CreateHasValueParameterRule ( _
	parameter As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateHasValueParameterRule(
	ElementId^ parameter
)

Parameters

parameter
Type: Autodesk.Revit.DB ElementId
The parameter to be evaluated by the filter.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also