ImageTypeOptions Constructor (String)


Constructs a new instance of the ImageTypeOptions object.

The provided string path must specify a local file. The path can be absolute or relative to the project's location. ImageType will respectively use an absolute or relative path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since: 2020

Syntax

C#
public ImageTypeOptions(
	string path
)
Visual Basic
Public Sub New ( _
	path As String _
)
Visual C++
public:
ImageTypeOptions(
	String^ path
)

Parameters

path
Type: System String
The local file path that specifies the image to be used.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also