DivisionRuleId Property


Id of the 'DivisionRule' which is used to augment the cutting sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2013

Syntax

C#
public ElementId DivisionRuleId { get; set; }
Visual Basic
Public Property DivisionRuleId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ DivisionRuleId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: The provided element id cannot be assigned as a division rule to this PartMakerMethodToDivideVolumes.
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also