Moves the selected analytical spaces from the identified zone equipment to another target zone equipment.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document where the zone equipment and the analytical spaces exist.
- analyticalSpaceSet
- Type: System.Collections.Generic ISet ElementId
The specified analytical spaces to move.
- originalZoneEquipmentId
- Type: Autodesk.Revit.DB ElementId
The original equipment where the analytical spaces will be removed. If passing invalidElementId, the existing zone equipment is not removed.
- targetZoneEquipmentId
- Type: Autodesk.Revit.DB ElementId
The target zone equipment where the analytical spaces will be associated. If passing invalidElementId, the analytical spaces will not be assigned to any new zone equipment.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |