ApplicationException Class


The exception that is thrown when a non-fatal application error occurs.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
[SerializableAttribute]
public class ApplicationException : Exception
Visual Basic
<SerializableAttribute> _
Public Class ApplicationException _
	Inherits Exception
Visual C++
[SerializableAttribute]
public ref class ApplicationException : public Exception

Remarks

This class is the base class of all Revit specified exceptions.

Inheritance Hierarchy

See Also