RevitAPIPreEventArgs Class


The class is used as a base class for the arguments for any pre-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011

Syntax

C#
public class RevitAPIPreEventArgs : RevitAPIEventArgs
Visual Basic
Public Class RevitAPIPreEventArgs _
	Inherits RevitAPIEventArgs
Visual C++
public ref class RevitAPIPreEventArgs : public RevitAPIEventArgs

Remarks

A pre-event is the event raised before executing the process that was related with the event.

Inheritance Hierarchy

See Also