The initial file name to be shown for this save operation.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
This would typically be a name derived by the application that matches the purpose of the save operation it intends to do. The user is permitted to alter the initial file name.
If the extension is not included, the file would be given the selected file extension for the active filter (when saved). If the extension is included, it will be ignored if the extension does not match one of the possible filter extensions. When not set, the file name entry field in the dialog will be blank and the user will have to enter a file name.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | When setting this property: initialFileName cannot include prohibited unprintable characters. |
Autodesk.Revit.Exceptions ArgumentNullException | When setting this property: A non-optional argument was NULL |