Creates a new phase filter with default status presentation.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- name
- Type: System String
The name.
Return Value
The newly created phase filter.Remarks
The default status presentation is ShowByCategory for New status, and ShowOverriden for Existing, Demolished and Temporary statuses.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | name is already in use. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |