Error states for the Rebar Coupler
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
ValidationSuccessfuly | Bars can be coupled |
IncorrectInputData | Cannot place rebar coupler. |
DifferentLayout | The rebar sets have different numbers of bars. |
BarsNotTouching | The selected ends of the bars are too far apart. |
IncorrectEndTreatmentHook | The coupler cannot be placed at an end that already has a hook. |
IncorrectEndTreatmentCoupler | The coupler cannot be placed at an end that already has a coupler. |
BarSegementsAreNotParallel | The selected legs are not aligned. |
BarSegmentsAreNotOnSameLine | The selected legs are not aligned. |
InconsistentShape | One of the selected bars has an incorrect shape. |
InvalidDiameter | The selected coupler type cannot be applied to the selected bar size(s). |
CurvesOtherThanLine | Cannot place rebar couplers on circular legs. |
BarSegmentSmallerThanEngagement | The selected leg is shorter than the bar engagement. |
VaryingDistanceBetweenDistributionsBars | All the bars from the selected sets, which need to be connected, must be separated by the same distance. |
ArcsHaveDifferentRadii | Cannot place rebar couplers on arcs with different radii. |
ArcsHaveDifferentCenters | Cannot place rebar couplers on arcs with different centers. |
ArcToStraightSegment | Cannot connect by coupler a straight segment with an arc segment. |