Creates a building type element.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- name
- Type: System String
The building type name.
Return Value
The new building type.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters. -or- The given value for name is already in use as a building type name. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |