RevitAPISingleEventArgs Class


The class is used as a base class for arguments of any single-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011

Syntax

C#
public class RevitAPISingleEventArgs : RevitAPIEventArgs
Visual Basic
Public Class RevitAPISingleEventArgs _
	Inherits RevitAPIEventArgs
Visual C++
public ref class RevitAPISingleEventArgs : public RevitAPIEventArgs

Remarks

A single event is an event that is not directly related to another event, meaning that there is no corresponding pre-event or post-event surrounding a single event.

Inheritance Hierarchy

See Also