If the DimensionStyle is LinearFixed, it cannot be created in a 3D View. If the DimensionStyle is Linear, it cannot be created in a 3D View if the view direction is perpendicular to the current work plane normal. Returns true if the ownerViewId is not a 3D view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document for the multi-reference annotation.
- ownerViewId
- Type: Autodesk.Revit.DB ElementId
The view in which the multi-reference annotation will appear.
- options
- Type: Autodesk.Revit.DB MultiReferenceAnnotationOptions
Options containing the references which the dimension will witness.
Return Value
True if the view is suitable for placing the MultiReferenceAnnotation. False otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |