Converts the set of MEP design elements into fabrication parts.
Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- selection
- Type: System.Collections.Generic ISet ElementId
The set of element identifiers to convert from MEP design elements to fabrication parts.
- serviceId
- Type: System Int32
The identifier of the fabrication service.
Remarks
After this method has been invoked, call:
- GetConvertedFabricationParts to get a set of element identifiers for the newly created fabrication parts.
- GetElementsWithOpenConnector to get a set of fabrication part or MEP design element identifiers with open connectors, caused by fittings failing to convert.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | the selection contains invalid elements to convert. -or- the specified fabrication service is not valid for all domains in the selection. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | no fabrication configuration is loaded. |