If true the ImageTypeOptions can be used to create or reload an ImageType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
Return Value
Returns True if the options can be used to create or reload an ImageType. False otherwise.Remarks
This method returns true if all the following checks are true:
- The Path points to a file that is a supported image file type.
- The Path points to a file that is not encrypted, which can happen for PDF files.
- The Path points to a file that contains the specified PageNumber.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |