Overrides the default service button exclusions, used by Route and Fill, Design to Fabrication, or Multi Point Routing for the current user and session only.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2017 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- groupIndex
- Type: System Int32
The index of the service group to exclude the service button from.
- buttonIndex
- Type: System Int32
The index of the service button to exclude.
- exclude
- Type: System Boolean
Pass true to exclude from being used by Route and Fill or Design to Fabrication.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | the index groupIndex is not larger or equal to 0 and less than GroupCount |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |