Create a CurveUV from a bounded 3D Curve lying in the XY plane.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curve3D
- Type: Autodesk.Revit.DB Curve
The input bounded 3D Curve lying in the XY plane (i.e., z = 0 everywhere along the curve).
Return Value
The newly created CurveUV.Remarks
The XY plane is identified with the uv parameter space of the surface to which this SurfParamSpaceCurve refers.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input Curve is not a bounded 3D Curve lying in the XY plane (i.e., z = 0 everywhere along the curve). |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |