IsValidSymbol Method (ForgeTypeId)


Checks whether a symbol is valid for the unit in this FormatOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
public bool IsValidSymbol(
	ForgeTypeId symbolTypeId
)
Visual Basic
Public Function IsValidSymbol ( _
	symbolTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
bool IsValidSymbol(
	ForgeTypeId^ symbolTypeId
)

Parameters

symbolTypeId
Type: Autodesk.Revit.DB ForgeTypeId
Identifier of the symbol to check.

Return Value

True if the symbol is valid, false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException UseDefault is true in this FormatOptions.

See Also