Obtains the IFC class name associated to a given category id for the current export.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- catId
- Type: Autodesk.Revit.DB ElementId
The category id.
- exporterIFC
- Type: Autodesk.Revit.DB.IFC ExporterIFC
The exporter.
Return Value
The IFC class name. This is an empty string if the element should not be exported because it is not found in the mapping file.Remarks
IFC class names are affected by the user's entries in the mapping file set for a given export operation.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |