The physical location of the element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
Remarks
Setting this property is not supported for some elements supporting LocationPoints, such as SpotDimensions.
Examples

void LocationMove(FamilyInstance column)
{
LocationPoint columnPoint = column.Location as LocationPoint;
if (null != columnPoint)
{
XYZ newLocation = new XYZ(10, 20, 0);
// Move the column to the new location
columnPoint.Point = newLocation;
}
}

Private Sub LocationMove(column As FamilyInstance)
Dim columnPoint As LocationPoint = TryCast(column.Location, LocationPoint)
If columnPoint IsNot Nothing Then
Dim newLocation As New XYZ(10, 20, 0)
' Move the column to the new location
columnPoint.Point = newLocation
End If
End Sub