Constructs a new ExportLayerKey with categoryName, subCategoryName and a special type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categoryName
- Type: System String
The category name for the layer key.
- subCategoryName
- Type: System String
The subCategoryName for the layer key.
- num
- Type: Autodesk.Revit.DB SpecialType
The special type for layer key.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |