DocumentSaveToLocalProgressChangedEventArgs Class


The event arguments used during the save to local phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged] .

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017 Subscription Update

Syntax

C#
public class DocumentSaveToLocalProgressChangedEventArgs : WorksharedOperationProgressChangedEventArgs
Visual Basic
Public Class DocumentSaveToLocalProgressChangedEventArgs _
	Inherits WorksharedOperationProgressChangedEventArgs
Visual C++
public ref class DocumentSaveToLocalProgressChangedEventArgs : public WorksharedOperationProgressChangedEventArgs

Remarks

It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time. Name correction - it is renamed from 'DocumentSaveToLocalProgessChangedEventArgs' released since 2017 Subscription Update.

Inheritance Hierarchy

See Also