GetValidCategoriesForEmbeddedSchedule Method


Get all categories that can be used for an embedded ScheduleDefinition in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013

Syntax

C#
public ICollection<ElementId> GetValidCategoriesForEmbeddedSchedule()
Visual Basic
Public Function GetValidCategoriesForEmbeddedSchedule As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetValidCategoriesForEmbeddedSchedule()

Return Value

The IDs of all valid categories.

See Also