AnalyticalModel Class


AnalyticalModel represents the Analytical Model portion of a given Structural Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011

Syntax

C#
public class AnalyticalModel : Element
Visual Basic
Public Class AnalyticalModel _
	Inherits Element
Visual C++
public ref class AnalyticalModel : public Element

Remarks

AnalyticalModel is made up of the following information:
  • Curves, representing the graphical representation of the Element with respect to analysis.
  • Support Information.
  • Adjustment Information, both Manual and Automatic.
  • Parameter Information, including projection, hard points, approximation, and rigid links.
  • Analytical Offset.
Specific options are available in specialized classes:
  • AnalyticalModelSurface - represents analytical model for Structural Floor, Structural Foundation Slab and Structural Wall.
  • AnalyticalModelStick - represents analytical model for Structural Framing Beam, Structural Framing Brace and Structural Column.
  • AnalyticalModelColumn - represents analytical model for Structural Column.

Inheritance Hierarchy

See Also