Test the category id to make sure the category is allowed for a DirectShape or DirectShapeType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categoryId
- Type: Autodesk.Revit.DB ElementId
Category id to be tested.
- doc
- Type: Autodesk.Revit.DB Document
Document to look up the category by id.
Return Value
True if the category is allowed for a DirectShape or DirectShapeType, false if not.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |