Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- famInst
- Type: Autodesk.Revit.DB FamilyInstance
The FamilyInstance
Return Value
The Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.Remarks
The output contains shape handle point ref ids. If there are no shape handle points defined in the Family then the output is empty.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | This operation failed. |