Zoom and center the view to a specified rectangle.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- viewCorner1
- Type: Autodesk.Revit.DB XYZ
A corner of the desired view rectangle in model coordinates.
- viewCorner2
- Type: Autodesk.Revit.DB XYZ
The opposite corner of the desired view rectangle in model coordinates.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |