IsProjectLocationNameUnique Method (Document, String, ElementId)


Verifies that there is no existing ProjectLocation with the given name belonging to the given SiteLocation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019

Syntax

C#
public static bool IsProjectLocationNameUnique(
	Document document,
	string name,
	ElementId siteLocationId
)
Visual Basic
Public Shared Function IsProjectLocationNameUnique ( _
	document As Document, _
	name As String, _
	siteLocationId As ElementId _
) As Boolean
Visual C++
public:
static bool IsProjectLocationNameUnique(
	Document^ document, 
	String^ name, 
	ElementId^ siteLocationId
)

Parameters

document
Type: Autodesk.Revit.DB Document
The document to check.
name
Type: System String
The name to check.
siteLocationId
Type: Autodesk.Revit.DB ElementId
The ElementId of the SiteLocation which the ProjectLocation belongs to.

Return Value

True if the name is unused (among ProjectLocations). False otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also