Add segments to the gutter.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- targetRef
- Type: Autodesk.Revit.DB Reference
Segment's reference on which want to be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | This exception will be thrown in following cases: 1. Input targetRef is null. 2. Input targetRef is not null but contains nothing. |
Autodesk.Revit.Exceptions InvalidOperationException | This exception will be thrown in following cases: 1. Input targetRef has already been added into the gutter. 2. Internal code fails to create the segment object. 3. Regeneration fails. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | This exception will be thrown if the reference is not suitable for creating a gutter as required. The reference allowed is : 1. Model Line 2. Roof's horizontal edges 3. Soffit's horizontal edges 4. Fascia's horizontal edges |