AddSegment Method


Add segments to the gutter.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public override void AddSegment(
	Reference targetRef
)
Visual Basic
Public Overrides Sub AddSegment ( _
	targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
	Reference^ targetRef
) override

Parameters

targetRef
Type: Autodesk.Revit.DBReference
Segment's reference on which want to be added.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException This exception will be thrown in following cases: 1. Input targetRef is null. 2. Input targetRef is not null but contains nothing.
Autodesk.Revit.ExceptionsInvalidOperationException This exception will be thrown in following cases: 1. Input targetRef has already been added into the gutter. 2. Internal code fails to create the segment object. 3. Regeneration fails.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException This exception will be thrown if the reference is not suitable for creating a gutter as required. The reference allowed is : 1. Model Line 2. Roof's horizontal edges 3. Soffit's horizontal edges 4. Fascia's horizontal edges

See Also