Returns all DirectContext3D handle instances of the given category in the document.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDocument
- Type: Autodesk.Revit.DB Document
The document.
- handleCategory
- Type: Autodesk.Revit.DB ElementId
A category of DirectContext3D handles.
Return Value
The set of DirectContext3D handle instances of the given category.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | the category ID handleCategory is not valid for DirectContext3D handles. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |