GetDirectContext3DHandleInstances Method


Direct Context 3DDocument Utils Get Direct Context 3DHandle Instances Method

Returns all DirectContext3D handle instances of the given category in the document.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ISet<ElementId> GetDirectContext3DHandleInstances(
	Document aDocument,
	ElementId handleCategory
)

Parameters

aDocument Document
The document.
handleCategory ElementId
A category of DirectContext3D handles.

Return Value

ISet ElementId
The set of DirectContext3D handle instances of the given category.
Exceptions
Exception Condition
ArgumentException the category ID handleCategory is not valid for DirectContext3D handles.
ArgumentNullException A non-optional argument was null
See Also