The position and orientation of the ReferencePoint.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- coordinateSystem
- Type: Autodesk.Revit.DB Transform
Remarks
The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ. The basis vectors must be unit length and mutually perpendicular. Whenever the Reference property is not a null reference ( Nothing in Visual Basic) , changing the CoordinateSystem property has a compound effect. First the point is moved to the specified location. Then the point is moved to conform to its Reference, by the shortest possible distance.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when coordinateSystem does not specify an orthonormal basis. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when CoordinateSystem is set while the Reference property is not a null reference ( Nothing in Visual Basic) , and the ReferencePoint is unable to move to the new location. |