SetCoordinateSystem Method


Reference Point Set Coordinate System Method

The position and orientation of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetCoordinateSystem(
	Transform coordinateSystem
)

Parameters

coordinateSystem Transform
Exceptions
Exception Condition
ArgumentException Thrown when coordinateSystem does not specify an orthonormal basis.
InvalidOperationException Thrown when CoordinateSystem is set while the Reference property is not , and the ReferencePoint is unable to move to the new location.
Remarks
The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ. The basis vectors must be unit length and mutually perpendicular. Whenever the Reference property is not , changing the CoordinateSystem property has a compound effect. First the point is moved to the specified location. Then the point is moved to conform to its Reference, by the shortest possible distance.
See Also