Gets the DocumentVersion that corresponds to a document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
The document whose DocumentVersion will be returned.
Return Value
The DocumentVersion corresponding to the given document.Remarks
This function can be combined with IsModified to see whether a document in memory is different from a version on disk. The documents are different if the document is modified or if the two DocumentVersions differ.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |