GetDocumentVersion Method


Document Get Document Version Method

Gets the DocumentVersion that corresponds to a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static DocumentVersion GetDocumentVersion(
	Document doc
)

Parameters

doc Document
The document whose DocumentVersion will be returned.

Return Value

DocumentVersion
The DocumentVersion corresponding to the given document.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This function can be combined with IsModified to see whether a document in memory is different from a version on disk. The documents are different if the document is modified or if the two DocumentVersions differ.
See Also