Remove existing shared parameter as a dependency for the calculation of the rebar curves.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- parameterId
- Type: Autodesk.Revit.DB ElementId
ElementId of the shared parameter to be removed.
Remarks
The input parameter needs to be bound to the Rebar element
The rebar element needs to have a valid external server
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions InvalidOperationException | This RebarFreeFormAccessor Rebar doesn't contain a valid server GUID. -or- parameterId is a parameter that is not bound to the Rebar element category. |