Remove existing shared parameter as a dependency for the calculation of the rebar curves.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- parameterId
- Type: Autodesk.Revit.DBElementId
ElementId of the shared parameter to be removed.
Remarks
The input parameter needs to be bound to the Rebar element
The rebar element needs to have a valid external server
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | This RebarFreeFormAccessor Rebar doesn't contain a valid server GUID. -or- parameterId is a parameter that is not bound to the Rebar element category. |