Creates a fascia along a reference array.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- FasciaType
- Type: Autodesk.Revit.DB.Architecture FasciaType
The type of the fascia to create
- references
- Type: Autodesk.Revit.DB ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the fascia.
Return Value
If successful a new fascia object within the project, otherwise a null reference ( Nothing in Visual Basic) .Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if the fascia type does not exist in the given document. |