NewFascia Method (FasciaType, ReferenceArray)


Document New Fascia(Fascia Type, Reference Array) Method

Creates a fascia along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Fascia NewFascia(
	FasciaType FasciaType,
	ReferenceArray references
)

Parameters

FasciaType FasciaType
The type of the fascia to create
references ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the fascia.

Return Value

Fascia
If successful a new fascia object within the project, otherwise .
Exceptions
Exception Condition
ArgumentException Thrown if the fascia type does not exist in the given document.
See Also