SpotBeamAngle Property


The spot beam angle.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public double SpotBeamAngle { get; set; }
Visual Basic
Public Property SpotBeamAngle As Double
	Get
	Set
Visual C++
public:
property double SpotBeamAngle {
	double get ();
	void set (double value);
}

Field Value

The spot beam angle as a numerical value in radians between 0 and (8/9)*PI.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: The angle is not valid because it is not between 1.0e-2 and 160.0.

See Also